
1 © 2013 Spansion Inc.  

Tutorial 

How to use IAR EWARM with Spansion templates 
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Warranty and Disclaimer 

The use of the deliverables (e.g. software, application examples, target boards, evaluation boards, starter kits, schematics,  

engineering samples of IC‟s etc.) is subject to the conditions of Spansion as set out in (i) the  

terms of the License Agreement and/or the Sale and Purchase Agreement under which agreements the Product has been delivered,  

(ii) the technical descriptions and (iii) all accompanying written materials. 

 

Please note that the deliverables are intended for and must only be used for reference in an evaluation laboratory environment. 

The software deliverables are provided on an as-is basis without charge and are subject to alterations. It is the user‟s obligation to  

fully test the software in its environment and to ensure proper functionality, qualification and compliance with component  

specifications. 

 

Regarding hardware deliverables, Spansion warrants that they will be free from defects in material and workmanship under use and  

service as specified in the accompanying written materials for a duration of 1 year from the date of receipt by the customer. 

Should a hardware deliverable turn out to be defect, Spansion‟s entire liability and the customer‟s exclusive remedy shall be, at Spansion´s 

 sole discretion, either return of the purchase price and the license fee, or replacement of the hardware deliverable or parts thereof, if  

the deliverable is returned to Spansion in original packing and without further defects resulting from the customer‟s use or the transport.  

However, this warranty is excluded if the defect has resulted from an accident not attributable to Spansion, or abuse or  

misapplication attributable to the customer or any other third party not relating to Spansion or to unauthorised decompiling and/or  

reverse engineering and/or disassembling. 

 

Spansion does not warrant that the deliverables do not infringe any third party intellectual property right (IPR). In the event that the  

deliverables infringe a third party IPR it is the sole responsibility of the customer to obtain necessary licenses to continue the usage  

of the deliverable. 

 

In the event the software deliverables include the use of open source components, the provisions of the governing open source  

license agreement shall apply with respect to such software deliverables.  

To the maximum extent permitted by applicable law Spansion disclaims all other warranties, whether express or implied, in particular,  

but not limited to, warranties of merchantability and fitness for a particular purpose for which the deliverables are not designated. 

To the maximum extent permitted by applicable law, Spansion‟s liability is restricted to intention and gross negligence. Spansion is not liable  

for consequential damages. 

 

Should one of the above stipulations be or become invalid and/or unenforceable, the remaining stipulations shall stay in full  effect. 

The contents of this document are subject to change without a prior notice, thus contact Spansion about the latest one. 

 

This board and its deliverables must only be used for test applications in an  

evaluation laboratory environment. 
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Debugging (IAR EWARM) 
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Debugging (IAR EWARM) 

IAR Development Tools (Software) 

 EWARM-KS (Kickstart) 

− 32K C/C++ Compiler, Assembler, IAR Embedded Workbench, 
Debugger/Simulator, no library support 

 EWARM-EV (Evaluation) 

− 30 day full verison of C/C++ Compiler, Assembler, IAR Embedded Workbench, 
Debugger/Simulator 

 EWARM-BS (Base Line) 

− 256K C/C++ Compiler, Assembler, IAR Embedded Workbench, 
Debugger/Simulator 

 EWARM (Full Version) 

− C/C++ Compiler, Assembler, IAR Embedded Workbench, Debugger/Simulator 

 EWARM-CM (Cortex M Series) 

− C/C++ Compiler, Assembler, IAR Embedded Workbench, Debugger/Simulator 

 

Free download 

Free download 
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Debugging (IAR EWARM) 

IAR Development Tools (Hardware) 

 J-LINK ARM Lite 

− 20-Pin JTAG to USB adapter (only 3.3 Volt support) 

 J-LINK (JTAG adapter for ARM) 

− 20-Pin JTAG to USB adapter 

 J-TRACE for ARM Cortex M3 (JTAG trace adapter for ARM) 

− 20-Pin JTAG to USB adapter 

− 20-Pin JTAG ETM to USB adapter 
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Debugging (IAR EWARM) 

Installation 

 Download latest version of EWARM from IAR Website 

− EWARM 30-day Evaluation Version 

 http://supp.iar.com/Download/SW/?item=EWARM-EVAL 

− EWARM 32K Kickstart Version 

 http://supp.iar.com/Download/SW/?item=EWARM-KS32 

 Install EWARM 

 Install J-LINK Debugger 

− Connect J-LINK to USB Port and follow installation advices 

 Drivers: 
<Installation_Path>\IAR Systems\Embedded Workbench 
x.y\arm\drivers\Jlink\  x64 or x86    

 Start EWARM Workbench 

 

http://supp.iar.com/Download/SW/?item=EWARM-EVAL
http://supp.iar.com/Download/SW/?item=EWARM-EVAL
http://supp.iar.com/Download/SW/?item=EWARM-EVAL
http://supp.iar.com/Download/SW/?item=EWARM-KS32
http://supp.iar.com/Download/SW/?item=EWARM-KS32
http://supp.iar.com/Download/SW/?item=EWARM-KS32
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Debugging (IAR EWARM) 

Getting Started 

 IAR Information Center 

− Getting Started 

− User Guides 

− Example Projects 

− Tutorials 

− Support 

− Release Notes 

 

− Can always be displayed 

by: Help → Information 

Center 
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Debugging (IAR EWARM) 

Choose Example Project 

 Choose Manufacturer 

− Use Fujitsu 

− Use MB9BF500 

− Use 

IAR KSK-MB9BF506 

− Open a project 

 Browse to folder, 

if necessary 
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Debugging (IAR EWARM) 

Main Window 

 IAR Workbench 

− Workspace on left side 
of Workbench window 

 Choose: 
View→Workspace, 
if hidden 

− Source files on right 
side of Workbench 
window as tabbed 
windows 

 

− Project can 
alternatively be 
opened by: 
File→Open→ 
Workspace→*.eww  

 



10 © 2013 Spansion Inc.  

Debugging (IAR EWARM) 

Menu Bar 

File Control 
(new, open, 

save, etc.) 

Edit Control 
(cut, copy, paste, 

undo, redo) 

Configuration 

Control 
(e.g. RAM or ROM 

debugging) 

Navigation Control 
(Find, Bookmarks, File 

Navigation, etc.) 

Build Control 
(compile, make, 

stop build) 

Debug Control 
(Breakpoint, start 

Debug w/ and w/o 

download) 
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Debugging (IAR EWARM) 

Workspace Window 

Project Name 

Sub Folder Modules 

Main Modules 

Module Includes 

Project Description 

Project Built Output 
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Debugging (IAR EWARM) 

Making Project 

 Use Make-Icon (      ), <F7> or 

Menu: Project→Make 

 Check for no errors in Output window 

below 

 

 Build errors are indicated by       or 

in Output window and Source view 
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Debugging (IAR EWARM) 

Download to Target and Start Debugging 

 Use       Icon, <Ctrl>-D, or Project→Download and Debug 

 A new menu bar will occur on sucessful connection to target 

Reset 

Target 

Stop 

Step 

Over 

Step 

Into 

Step 

Out 

Next 

Statement 

Run to 

Cursor 

Run 

End 

Debugging 

Trace 

Control 
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Debugging (IAR EWARM) 

Debug Windows 

 Source Window 

− The Source windows do not change contents but get additional information 

 Current line (PC): 

 Halted on breakpoint: 

 Halted on data break (example):   

 Disassembly Window 

− Shows "pure" disassebly view 

− Shows mixed mode view 

 



15 © 2013 Spansion Inc.  

Debugging (IAR EWARM) 

Debug Windows 

 Memory Window 

− The Memory window is a tabbed part of the Output window 

 

 

 

 Register View 

− Some Registers are grouped and can be unfolded 
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Debugging (IAR EWARM) 

Debug Windows 

 Breakpoint Window 

− The Breakpoint window is a tabbed part of the Output window 

 

 

 

 

− Breakpoints can be enabled and disabled in 

 Source window         (      enabled,       disabled) 

 Breakpoint window   (      enabled,       disabled) 
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Debugging (IAR EWARM) 

Watch Windows 

 Watch Windows 

− Watch 

 Expressions/Variables have to 
be added by user and are 
updated by Halt/Breakpoint 

− Locals 

 Functional local Expressions/Variables are added by Workbench itself, if PC is in function 
context 

− Statics 

 Functional local Expressions/Variables are added by Workbench itself, if PC is in function 
context 

− Live Watch 

 Expressions/Variables have to be added by user and are updated during runtime (with 
performance impact) 

− Auto 

 Expressions/Variables are added by Workbench itself near the current PC in 
Halt/Breakpoint 
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Debugging (IAR EWARM) 

Debug Windows 

 Watch Windows 

− Quick Watch 

 The Quick watch allows the user to calculate and recalculate expressions 

even with variables 

 

 

 

 

 

 The drop down menu memorizes the last typed contents 
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Debugging (IAR EWARM) 

Debug Windows 

 Symbolic Memory 

− References the project Symbols to a memory view 

 

 

 

 

 Call Stack 

− Can be displayed with or without called arguments 

− Last called function (current) is marked with green arrow, callers are below 
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Debugging (IAR EWARM) 

Debug Windows 

 Stack 

− Show current Stack context with local variables (if existing), including graphical stack usage 
(if enabled) 

 Terminal I/O 

− Allows debug information printed-out via  printf() function 

− Log can be output to a file 

 Code Coverage 

− Shows the percentage of code covered by application run 

 Needs ETM connection to Debugger (J-Trace) 

 Profiling 

− Shows the number of calls of each project function by application run 

 Activated by „Show details“ and/or „Autorefresh“  

 Symbols 

− Shows the project„s symbols in a list with their address references 
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Debugging with CMSIS-DAP 

Definition (ARM-Webpage) 

 CMSIS-DAP is the interface firmware for a Debug Unit that connects the Debug 

Port to USB. Debuggers, which execute on a host computer, connect via USB 

to the Debug Unit and to the Device that runs the application software. The 

Debug Unit connects via JTAG or SW to the target Device. ARM Cortex 

processors provide the CoreSight Debug and Trace Unit. CMSIS-DAP supports 

target devices that contain one or more Cortex processors. 

 

http://www.arm.com/products/system-ip/debug-trace/index.php
http://www.arm.com/products/system-ip/debug-trace/index.php
http://www.arm.com/products/system-ip/debug-trace/index.php
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Debugging with CMSIS-DAP 

Additional Features 

 Spansion CMSIS-DAP implementation offers 

− 1 channel JTAG or SWD (Single Wire Debug) 

− Additional 1 channel UART / RS232 

 

UART / RS232 

JTAG / SWD 

USB 

& 
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Debugging with CMSIS-DAP 

Setup in IAR EWARM (1) 

 Navigate to project options: 

− Via Files-List 

 Right-click at the project 

 Select „Options...“ 

 

− Or via menu „Project“ 

 Select „Options...“ 

 

 

 

See also Chapter Debugging (IAR EWARM) 
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Debugging with CMSIS-DAP 

Setup in IAR EWARM (2) 

 Setup Project Debbuger Options 

− (1) Navigate to Debugger 

− (2) Select tab „Setup“ 

− (3) Select Driver „CMSIS-DAP“ 

 

 

 

− (4) Select in „CMSIS-DAP“ 

− (5) Select tab „JTAG/SWD“ 

− (6) Select SWD 

 

 

1 

2 

3 

4 

5 

6 

See also Chapter Debugging (IAR EWARM) 
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Debugging (IAR EWARM) 

JTAG Connection 

 JTAG Connection Type (J-LINK) 

− JTAG 

− Serial Wire Debugging (SWD) 

 Chose: 

Options → General Options 

 → Library Configuration 

 → Library Low-Level 

Interface Implementation 

 

 Check: 

- Via semihosting 

      for JTAG and SWD 

- Via SWD 

      for only SWD 
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Debugging (IAR EWARM) 

JTAG Connection 

 JTAG Connection Type (J-LINK) 

− JTAG 

− Serial Wire Debugging (SWD) 

 Chose: 

Options → J-Link/J-Trace 

 → Connection 

 → Interface 

 

 Check: 

- JTAG 

- SWD 

      when semihosting 

      was chosen 

- Only SWD (greyed) 

      when SWD only was 

      chosen 
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Debugging (IAR EWARM) 

Simulator 

 Mark Project File in Workspace 

 Choose Project→Options 

 Choose Simulator in Debugger Setup 

 Start Simulator with usual      Icon 
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www.spansion.com 

 Spansion®, the Spansion logo, MirrorBit®, MirrorBit® Eclipse™ and combinations thereof are trademarks and registered 

trademarks of Spansion LLC in the United States and other countries. Other names used are for informational purposes 

only and may be trademarks of their respective owners. 

 This document is for informational purposes only and subject to change without notice. Spansion does not represent that 

it is complete, accurate or up-to-date; it is provided “AS IS.” To the maximum extent permitted by law, Spansion disclaims 

any liability for loss or damages arising from use of or reliance on this document. 


